Benchmarks

General discussion on MAME, MARP, or whatever else that doesn't belong in any of the other forums

Moderators: mahlemiut, seymour, QRS

Benchmarks

Postby mahlemiut » Sat Feb 28, 2004 6:08 am

Thought that it might be interesting to compare benchmarks. Using the attached batch file will help too. (Change the -rompath parameter to match the location of your ROMs first, if needed)

It may also be useful to compare across versions too.

System specs:
Athlon XP 3000+ (2.17GHz)
1024MB RAM
128MB GeForceFX 5200
Windows XP Pro SP1
MAME 0.79 (Win32 console)

The speeds:
Pacman 1,725.26fps
Malzak 1,187.75fps
Double Dragon [ddragon] 207.70fps
Twinbee Yahhoo! 229.24fps
Stun Runner 146.77fps
Mr Driller 39.19fps
Tekken 65.05fps
Cotton 2 47.04fps (Boot up sequence is loads faster than the game here)
- Barry Rodewald
MARP Assistant Web Maintainer
Image
User avatar
mahlemiut
Editor
 
Posts: 4105
Joined: Mon Feb 04, 2002 10:05 pm
Location: New Zealand

Postby mahlemiut » Sat Feb 28, 2004 6:54 am

Ok, the previous MAME version I used was Athlon XP optimised, so here are benchmarks for a non-optimised 0.79u1 build.

pacman 1,591.21
malzak 1,116.73
ddragon 257.13
tbyahhoo 223.52
stunrun 137.60
mrdrillr 37.40
tekken 67.34
cotton2 44.52
- Barry Rodewald
MARP Assistant Web Maintainer
Image
User avatar
mahlemiut
Editor
 
Posts: 4105
Joined: Mon Feb 04, 2002 10:05 pm
Location: New Zealand

Postby LordGaz » Sat Feb 28, 2004 10:18 am

*** Updated ***

System Spec:
OS: Microsoft Windows XP Home Edition Version 2002 Service Pack 1
CPU: AMD Athlon XP2000+ 1.68GHz
Memory: 512MB DDR (266MHz)
Graphics: NVIDEA GeForce4 Ti 4600 (128MB)
Sound: Creative Soundblaster Audigy
MAME: mame0.79b Command Line Version
Screen Resolution: 1152x864x32bbp

pacman: 357.83 fps
malzak: 362.48 fps
ddragon: 165.47 fps
tbyahhoo: 139.68 fps
stunrun: 88.67 fps
mrdrillr: 26.49 fps
tekken: 44.80 fps
cotton2: 33.37 fps
invaders: 432.30 fps

Surprising how an Athlon XP2000+ is about a third the speed of an XP3000+ one.

Gaz.
Last edited by LordGaz on Sun Feb 29, 2004 8:06 am, edited 2 times in total.
User avatar
LordGaz
MARP Knight
MARP Knight
 
Posts: 218
Joined: Sat Mar 09, 2002 5:07 pm
Location: London, UK

Postby Buttermaker » Sat Feb 28, 2004 10:46 am

LordGaz wrote:I'm not getting any display of the average fps after the test.

It's in the command line window after you exit the game. You must of course run the batch file from the command line.
Buttermaker
MARP Seer
MARP Seer
 
Posts: 788
Joined: Sun May 19, 2002 8:06 am

Postby DRN » Sat Feb 28, 2004 11:07 am

System Spec:
OS: Windows 2000
CPU: Pentium 4 3.2ghz (800fsb)
Memory: 512MB DDR PC3200
Graphics: NVIDIA GeForce4 MX 440 64Mb
Mame: MAME32 Plus! 0.79


pacman: 939.13
malzak: 1086.61
ddragon: 208.69
tbyahhoo: 228.55
stunrun: 121.06
mrdrillr: 53.78
tekken: 73.54
cotton2: 45.83


Let the AMD/Intel debate commence... :wink:
Darren
User avatar
DRN
MARP Knight
MARP Knight
 
Posts: 308
Joined: Wed Mar 06, 2002 10:37 am
Location: Somerset, UK

Postby LordGaz » Sat Feb 28, 2004 11:59 am

C:\DOCUME~1\Gaz\MYDOCU~1\EMULAT~1\MAME\versions\WOLF32~4>"C:\Documents and Settings\Gaz\My Documents\Emulators\MAME\versions\wolf32p-079\bench.bat" pacman

C:\DOCUME~1\Gaz\MYDOCU~1\EMULAT~1\MAME\versions\WOLF32~4>del .\nvram\pacman.nv
The system cannot find the file specified.

C:\DOCUME~1\Gaz\MYDOCU~1\EMULAT~1\MAME\versions\WOLF32~4>del .\cfg\pacman.cfg

C:\DOCUME~1\Gaz\MYDOCU~1\EMULAT~1\MAME\versions\WOLF32~4>wolf32p-079 pacman -norc -v -ftr 5000 -noafs -noswitchbpp -noswitchres -nothrottle -rdtsc -high_priority -skip_disclaimer -skip_gameinfo -noart -nomouse -nojoy -nogun -nosleep -nod3d -rompath "C:\Documents and Settings\Gaz\My Documents\Emulators\MAME\roms"

C:\DOCUME~1\Gaz\MYDOCU~1\EMULAT~1\MAME\versions\WOLF32~4>
===============================================

This is what I get, cut and pasted directly from the cmd window after the test. No sign of average fps :(.

Gaz

*** Edit ***
My list is updated for the standard 079b version, not Wolfmame.
Last edited by LordGaz on Sat Feb 28, 2004 12:47 pm, edited 2 times in total.
User avatar
LordGaz
MARP Knight
MARP Knight
 
Posts: 218
Joined: Sat Mar 09, 2002 5:07 pm
Location: London, UK

Postby LordGaz » Sat Feb 28, 2004 12:17 pm

del .\nvram\%1.nv
del .\cfg\%1.cfg
mame.exe %1 -norc -v -ftr 5000 -noafs -noswitchbpp -noswitchres -nothrottle -rdtsc -high_priority -skip_disclaimer -skip_gameinfo -noart -nomouse -nojoy -nogun -nosleep -nod3d -rompath c:\mame\roms;z:\roms

Just a thought, wouldn't it make sense to turn on -switchbpp and -switchres so that the benchmarks are run in the same screen mode for all?
User avatar
LordGaz
MARP Knight
MARP Knight
 
Posts: 218
Joined: Sat Mar 09, 2002 5:07 pm
Location: London, UK

Postby Buttermaker » Sat Feb 28, 2004 12:30 pm

I'm not sure what exactly you're doing Gaz, but first of all: start -> run -> cmd

Command.com is DOS emulation. Cmd.exe is the real NT command line.

Then go to your MAME dir and simply execute bench.bat.
Buttermaker
MARP Seer
MARP Seer
 
Posts: 788
Joined: Sun May 19, 2002 8:06 am

Postby LordGaz » Sat Feb 28, 2004 12:43 pm

That's exactly what I was doing, anyway I've just downloaded mame079b from mame.net and it works. I was using Wolfmame even though it says MAME32 Plus! 0.79 in the version window Barry ;). My list is updated for the standard version.
User avatar
LordGaz
MARP Knight
MARP Knight
 
Posts: 218
Joined: Sat Mar 09, 2002 5:07 pm
Location: London, UK

Postby Buttermaker » Sat Feb 28, 2004 1:10 pm

LordGaz wrote:I was using Wolfmame

But you were using the GUI executable and not the command line .exe.
Buttermaker
MARP Seer
MARP Seer
 
Posts: 788
Joined: Sun May 19, 2002 8:06 am

Postby Chad » Sat Feb 28, 2004 3:53 pm

OS: Win 98 or XP , *xp is nosound, p4 (1.2ghz)
CPU: Athlon MP 1800
Mem: 1G
Graphics: Nspitia Gf3 Ti200 64m
Sound: Audigy
Mame: official mame 79
Code: Select all
          79-98   79-xp 80-xp 81-xp 89-98 89-xp 89*xp 89-p4
pacman:  548.197 439.88 504.5 471.4 567.6 480.0 610.3 570.2
malzak:  551.007 437.92 508.3 458.9 578.5 514.5 589.9 457.0
ddragon: 163.060 150.69 145.3 137.5 134.5 129.9 218.1  83.1
tbyahhoo:138.785 129.21 137.2 132.2 138.4 136.4 190.0 121.8
stunrun:  86.690  81.58  78.9  77.7  79.6  78.5  85.4  53.1
mrdrillr: 24.838  24.17  24.7  24.5  23.5  23.4  23.6  21.4
tekken:   41.423         43.9  44.6  44.9  45.3  45.2  35.4
cotton2:  29.092         21.5  21.1  15.8  15.8  16.3  8.51
invaders:713.197 563.34 629.4 620.9 719.7 640.2 740.8 667.2
puzzloop:                                  76.9  78.9  61.1

interesting how i get aproximate numbers for the slow games compared to gaz's2000 but the fast games i can kick the 2000's butt, might be the complexity of the higher end video card, but it must be something. i'll try in xp later.

EDIT **** stupid XP crap, can't even perform as good as 98. bull operating system "upgrade".
Last edited by Chad on Fri Dec 10, 2004 6:07 pm, edited 9 times in total.
-skito
User avatar
Chad
Tournament Coordinator
 
Posts: 4463
Joined: Tue Mar 05, 2002 3:15 pm
Location: calif

Postby mahlemiut » Sat Feb 28, 2004 6:20 pm

Seeing as the resolution/bpp isn't changed, it's probably worth mentioning what video mode you are using. I'm using 1024x768x32bpp.

Benchmarks for MAME 0.79u4:
pacman 1604.94
malzak 1101.97
ddragon 228.34
tbyahhoo 218.39
stunrun 126.00
mrdrillr 37.29
tekken 65.32
cotton2 32.66
invaders 2342.20
- Barry Rodewald
MARP Assistant Web Maintainer
Image
User avatar
mahlemiut
Editor
 
Posts: 4105
Joined: Mon Feb 04, 2002 10:05 pm
Location: New Zealand

Postby mahlemiut » Tue Mar 23, 2004 8:13 am

Benchmarks for MAME 0.80 - no optimisations, AthlonXP 3000+, WinXP Pro SP1, 1024x768x32.

pacman 1620.58
malzak 1126.81
ddragon 229.04
tbyahhoo 221.79
stunrun 125.00
mrdrillr 37.22
tekken 65.87
cotton2 31.05
invaders 2348.86
- Barry Rodewald
MARP Assistant Web Maintainer
Image
User avatar
mahlemiut
Editor
 
Posts: 4105
Joined: Mon Feb 04, 2002 10:05 pm
Location: New Zealand

Postby tar » Tue Mar 23, 2004 10:34 am

AMD Athlon XP 1900+
256mb ram / 1.6ghz processor speed
ImageQuest V770+ RADEON 8500 series
Creative Sound Blaster PC1128 (WDM)
U.S Robotics 56k dial-up modem
microsoft windows '98
...........................................................
I played Lord Gaz's 127,000 on invaders at 5000%.
M35tg3 nosound , a year ago

Just now , pacman plays at 500% nosound + noartwork.
mame32 version 80

How many applications should be running?

motherboard?
User avatar
tar
MARPaholic
MARPaholic
 
Posts: 1209
Joined: Mon Aug 05, 2002 8:25 am
Location: ohio u.s.a.

Postby mahlemiut » Thu Apr 01, 2004 9:46 pm

Benchmarks for MAME 0.81:

Pacman [pacman]: 1567.61
Malzak [malzak]: 1141.19
Double Dragon [ddragon]: 222.14
Twinbee Yahhoo! [tbyahhoo]: 223.03
STUN Runner [stunrun]: 126.67
Mr. Driller [mrdrillr]: 37.32
Tekken [tekken]: 67.87
Cotton 2 [cotton2]: 31.04
Space Invaders [invaders]: 2347.77
Beastorizer [beastrzr]: 50.54 (now I wonder why I added that one... :))
- Barry Rodewald
MARP Assistant Web Maintainer
Image
User avatar
mahlemiut
Editor
 
Posts: 4105
Joined: Mon Feb 04, 2002 10:05 pm
Location: New Zealand

Next

Return to General

Who is online

Users browsing this forum: No registered users and 2 guests